TGUI Forum

General Category => Help requests => Topic started by: roccio on 07 July 2021, 10:42:14

Title: problem running 0.9
Post by: roccio on 07 July 2021, 10:42:14
Hello,
I am trying to port my application to v0.9 and after resolving all compiler errors when I try to run I get this error:

Unable to fing ingress point for ?getKerning@Font...

(See attached image).

Do you have any idea of what I am doing wrong?

Thanks
Title: Re: problem running 0.9
Post by: texus on 07 July 2021, 15:59:12
Where did you download SFML and TGUI?

I'm guessing that TGUI was build with a different SFML version than the one you are using in your project.
Title: Re: problem running 0.9
Post by: roccio on 07 July 2021, 16:05:52
Yes, I am trying a new SFML snapshot. So I should build tgui with it.
Title: Re: problem running 0.9
Post by: texus on 07 July 2021, 18:48:48
Yeah, the precompiled TGUI libraries from the website are only compatible with the SFML 2.5.1 release. When using an SFML snapshot then you must build TGUI yourself from the source code.