tgui 0.6 and sfml 2.1
« on: 28 July 2013, 16:42:57 »
Sfml 2.1 is released this morning, and i am wondering is it safe to use tgui 0.6 with sfml 2.1?

Thank you :)

*

texus

  • *****
  • 1161
    • View Profile
    • Texus's Blog
Re: tgui 0.6 and sfml 2.1
« Reply #1 on: 28 July 2013, 17:06:29 »
There will be no API breaking changes in SFML 2.x, so you can use tgui with any version.

You just have to make sure that your tgui library is compiled against the sfml library that you are using.
You can't just replace sfml 2.0 with sfml 2.1, you will have to recompile tgui.

Re: tgui 0.6 and sfml 2.1
« Reply #2 on: 28 July 2013, 18:31:12 »
I couldnt find diference between sfml 2.0 and 2.1. So i didnt know is sfml 2.1 is a bugfix release or api was changed. Yup since there is no sfml 2.1 on launchpad [yet?] i will have to build sfml and tgui from source. Am waiting for github to start working again to get tgui-0.6.

Thank you for your answer
wmbuRn