Text font issue
« on: 24 October 2013, 08:30:37 »
Hello,

I have some problem with text widget (EditBox, Label, ListBox, ...).
Fonts are not displayed, instead I get squares (one square instead of each letter).
But if I put multiple Label, this problem appears on the first Label widget, but not on the others.

If anybody has an idea...

TGUI : 0.6
SMFL : 2.0
GCC 4.6.3

Thank you !

*

texus

  • *****
  • 1143
    • View Profile
    • Texus's Blog
Re: Text font issue
« Reply #1 on: 24 October 2013, 09:33:44 »
On which operating system?

Do you have the same problem with just using sf::Text?

Could you provide a small code example which fails for you?

Re: Text font issue
« Reply #2 on: 24 October 2013, 11:38:36 »
My system is Ubuntu 12.04

I tried to reproduce the problem with http://tgui.eu/example-code/v06/full-example/

You will see the result in the screenshot.

Thank you for your help !

Re: Text font issue
« Reply #3 on: 24 October 2013, 11:47:43 »
Another interesting behavior :
- if my chatbox doesn't contain any scrollbar, there are some glitch
- when scrollbar appears, glitch disappears

*

texus

  • *****
  • 1143
    • View Profile
    • Texus's Blog
Re: Text font issue
« Reply #4 on: 24 October 2013, 11:52:29 »
This looks like it has more to do with your graphics driver than with tgui. I wouldn't have any idea what else could cause this.

But one question remained unanswered: can you reproduce it with just using sf::Text?

Edit: Also, are you compiling with the -std=c++0x flag?

Re: Text font issue
« Reply #5 on: 24 October 2013, 14:23:18 »
This looks like it has more to do with your graphics driver than with tgui. I wouldn't have any idea what else could cause this.

But one question remained unanswered: can you reproduce it with just using sf::Text?

Edit: Also, are you compiling with the -std=c++0x flag?

Yes, I'm using the c++0x flag.
I can't reproduce this problem with sf::Text, but I've flickering issue with this kind of text.

You're probably right about graphics driver, I tried my software on another linux machine without any problem.
Thank you for your fast answers !