LNK1107 on tgui-d.dll
« on: 19 March 2015, 11:28:12 »
hi everyone,

i tried to use tgui but when i try to compile my project i get
Code: [Select]
tgui-d.dll : fatal error LNK1107: Invalid file OR corrupt: impossible to read at 0x2E8
i tried to redownload the file but it didn't work either

is there a solution ?

*

texus

  • *****
  • 1161
    • View Profile
    • Texus's Blog
Re: LNK1107 on tgui-d.dll
« Reply #1 on: 19 March 2015, 11:57:56 »
Which packet did you download? What compiler are you using?

Edit: I just looked up a bit more info on the error, are you by any chance trying to link to the dll file? You must link against the lib files and just copy the dll files next to the exe, don't put the dll in the linker options.
« Last Edit: 20 March 2015, 00:03:48 by texus »

Re: LNK1107 on tgui-d.dll
« Reply #2 on: 26 March 2015, 08:05:07 »
i'm on VS 2013 Ultimate edition on Windows 7 64bits

i'll try your solution and see if it works

edit:you were right i made a mistake i was trying to link the dll file so it worked but i'm on 64bits so i need to compile tgui with cmake

i've done all the configuration with cmake, i have the solution but when i try to generate the project i have

Code: [Select]
error C2039: 'substring' : isn't a member of 'sf::String'
and i don't know why

i give you the project file

edit: i found out why it didn't worked i was using sfml 2.1 which didn't have a declaration of a method substring i made the update i'll try to compile

« Last Edit: 26 March 2015, 10:35:29 by synthetik »

Re: LNK1107 on tgui-d.dll
« Reply #3 on: 26 March 2015, 10:36:22 »
it didn't work either i'll try to compile it at home and bring it back at work thanks for your help :) i'll come again if i have any other problem