Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - che2a

Pages: [1]
1
Help requests / Re: listView and symbols
« on: 29 May 2020, 09:03:23 »
Yes, now it work
You teach me a good thing today :)

Thank you

2
Help requests / Re: listView and symbols
« on: 28 May 2020, 18:05:12 »
I use Codeblocks , it never worked for me to use wide strings with L"€"

I tried to change editor encoding settings but impossible i always have an error during the compilation

I would like to use visual studio but is not free...


3
Help requests / Re: listView and symbols
« on: 28 May 2020, 17:18:22 »
Thank you but when i use L"€"
I have error : converting to execution character set : Illegal byte sequence

When i use this symbol in sf::Text it is displayed correctly

4
Help requests / [solved] listView and symbols
« on: 28 May 2020, 16:01:11 »
Hello, the ListView widget does not display the € symbol

I tried with sf::String::FromUtf8 and utf16 but it not works

How i can display symbols ?

Thank you

str_annual_wages = std::to_string(drivers_vector[i]->contract->getAnnualWages()) + "€";

vect.push_back(sf::String::fromUtf8(str_annual_wages.begin(), str_annual_wages.end()));

// This is a part of my code, i use vectors to fill the listview columns

 

5
Help requests / Re: how get a widget and use it ?
« on: 26 May 2020, 18:29:38 »
Thank you it works !

And thank you for your work tgui is awesome :)

6
Help requests / how get a widget and use it ?
« on: 26 May 2020, 13:37:35 »
Hello, when i get a widget i have a widget::ptr

But i need to get the widget to use moveToFront() because he is displayed behind an another widget

I need to do something like that :
tgui::MenuBar::Ptr widget = gui->get<tgui::MenuBar>("MenuBar");
widget->moveTofront();
 

Thank you

7
Ok, i created new project on CodeBlocks, now it work, i don t know why it not work on my actual sfml project, i put the same build options but i get errors on my actual sfml project...

I will try to migrate my project

Hope i can and no have to rewrite all

Thank you a lot

8
I updated my drivers, problem is same

But i never used opengl with SFML, when i compile a test i get in console :

Warning : The created OpenGL context does not fully meet the settings that were requested
Requested : version = 3.0 ; depth bits = 32 : stencil bits = 8 ; AA level = 4 ; core = false ; debug = false ; sRGB = false;
Created: version = 4.6 ; depth bits = 24 : stencil bits = 8 ; AA level = 4 ; core = false ; debug = false ; sRGB = false;

9
I took  a screenshot of console

Yesterday i didn t see the error message that  SFML require support opengl 1.1

i tried this code :

Code: [Select]
#include <TGUI/TGUI.hpp>


int main()
{

    sf::RenderWindow window{{800, 600}, "Window"};
    tgui::Gui gui{window}; // Create the gui and attach it to the window

    tgui::Button::Ptr button = tgui::Button::create();
    tgui::EditBox::Ptr editBox = tgui::EditBox::create();

    //gui.add(button);
    //gui.add(editBox, "MyWidgetName");

    while (window.isOpen())
    {
        sf::Event event;
        while (window.pollEvent(event))
        {
            if (event.type == sf::Event::Closed)
                window.close();

            gui.handleEvent(event); // Pass the event to the widgets
        }

        window.clear();
        //gui.draw(); // Draw all widgets
        window.display();
    }
}

see attachment

10
If i do not add and draw i have no errors, if i create but no add and i draw i have error.
But i have to confirm you tomorrow when i go back to my computer
I will take some screenshots and post here

11
I have latest version of sfml 2.5.1
Sfml works fine

I didn t modified the code

When i try the first step of the tutorial code i get same errors...

I m on codeblocks i donwloaded precompiled version

12
General Discussion / Example: Scalable login screen - Error
« on: 18 May 2020, 16:59:04 »
Hello im  newbie, when i try the code from Scalable login screen for 0.8 version

i get this error (in loop) :

An internal OpenGL call failed in Texture.cpp(98).
Experssion:
    glFlush()
Error description:
    GL_INVALID_OPERATION
    The specified operation is not allowed in the current state.


Pages: [1]